composer require dingo/api:1.0.x@dev 安装报错 解决方案



按照Laravel学院上的dingo 安装方法 直接执行

composer require dingo/api:1.0.x@dev

得到的是下方的结果:

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install dingo/api v1.0.0-beta8
    - Conclusion: don't install dingo/api v1.0.0-beta7
    - Conclusion: don't install dingo/api v1.0.0-beta6
    - Conclusion: don't install dingo/api v1.0.0-beta5
    - Conclusion: don't install dingo/api v1.0.0-beta4
    - Conclusion: don't install dingo/api v1.0.0-beta3
    - Conclusion: don't install dingo/api v1.0.0-beta2
    - Conclusion: remove laravel/framework v5.5.36
    - Conclusion: don't install dingo/api v1.0.0-beta8|remove phpdocumentor/reflection-docblock 4.3.0
    |install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1
    - Conclusion: don't install dingo/api v1.0.0-beta8|don't install phpdocumentor/reflection-docblock 4.3.0
    |install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1
    - Conclusion: don't install dingo/api v1.0.0-beta8|remove phpdocumentor/reflection-docblock 4.3.0
    |install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1
    - Conclusion: don't install dingo/api v1.0.0-beta8|don't install phpdocumentor/reflection-docblock 4.3.0
    |install dingo/blueprint 0.2.2|install dingo/blueprint v0.2.0|install dingo/blueprint v0.2.1
    - Installation request for phpdocumentor/reflection-docblock (locked at 4.3.0)
     -> satisfiable by phpdocumentor/reflection-docblock[4.3.0].
    - Installation request for dingo/api 1.0.x@dev -> satisfiable by dingo/api[v1.0.0-beta1,
     v1.0.0-beta2, v1.0.0-beta3, v1.0.0-beta4, v1.0.0-beta5, v1.0.0-beta6, v1.0.0-beta7, v1.0.0-beta8].
    - Conclusion: don't install laravel/framework v5.5.36
    - dingo/api v1.0.0-beta1 requires illuminate/routing 5.1.* -> 
    satisfiable by illuminate/routing[v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, 
    v5.1.31, v5.1.41, v5.1.6, v5.1.8].
    - don't install illuminate/routing v5.1.1|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.13|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.16|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.2|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.20|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.22|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.25|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.28|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.30|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.31|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.41|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.6|don't install laravel/framework v5.5.36
    - don't install illuminate/routing v5.1.8|don't install laravel/framework v5.5.36
    - Installation request for laravel/framework (locked at v5.5.36, required as 5.5.*) -> satisfiable by laravel/framework[v5.5.36].


Installation failed, reverting ./composer.json to its original content.

网上有资料说是因为composer.json里已经有了

"dingo/api": "1.0.*@dev"

可是我检查自己的composer并未发现;

链接地址:http://bbs.earnp.com/article/385

但是我的并不是这个原因;

然后简单粗暴的方法就是

直接在require中添加上边那句

dingo/api": "1.0.*@dev

直接执行composer upadte 然后就可以看到

blob.png

MMP装好了。。。


上一篇 下一篇

评论



最新评论

daliangzao_qq_com: 1112 查看原文 12月03日 10:57
PHP笔记: ypengchao@126.com 查看原文 06月26日 11:38
PHP笔记: 用数据库 查看原文 06月26日 11:37
网站/shl设计: 如果关闭浏览器了,session就没有了呀。再打开浏览器不就可以重新登陆了。 查看原文 05月28日 15:26
网站/shl设计: 站长怎么联系你有给问题请教。 查看原文 05月28日 15:25

分享

扫一扫,快速分享到微信

赞助商